澳门威斯人8040 com-威澳门尼斯人8040com

您好,欢迎光临中投期货网站!今天是
您好,oBear,今天是
在线问卷调查| 联系大家| 网站地图| 威澳门尼斯人8040com| 加入收藏

交易策略

您在这里:澳门威斯人8040 com>财富中心>策略研究>交易策略

海龟交易系统公式

来源:中投期货    发布时间:2013-12-20    点击数:

{公称名称: 海龟交易系统}

input:N1(55,6,99),N2(20,2,99);
LC:=REF(CLOSE,1);
TR:=MAX((HIGH - LOW),MAX((HIGH - LC),(LC - LOW)));
ATR:=SMA(TR,20,1);
AA:=(HHV(HIGH,N1) - (2 * ATR));
BB:=CROSS(CLOSE,REF(HHV(HIGH,55),1));
SSS:=CROSS(MIN(MA(CLOSE,13),AA),CLOSE);
BBB:=BARSLAST(BB);
SSSB:=BARSLAST(SSS);
B1:=((BBB = 0) AND (REF(SSSB,1) < REF(BBB,1)));
B1B:=BARSLAST(B1);
B2:=((((BB = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (COUNT(BB,SSSB) < 3));
B2B:=BARSLAST(B2);
B3:=((((BB = 1) AND (B2B < B1B)) AND (COUNT(BB,SSSB) < 4)) AND (COUNT(BB,SSSB) > 2));
B3B:=BARSLAST(B3);
SS:=CROSS(MAX(AA,MA(CLOSE,13)),CLOSE);
SS1:=(((SS AND ((B3B < B2B) OR (B2B < B1B))) AND (SSSB > B1B)) AND (COUNT(SS,B2B) < 2));
SS1B:=BARSLAST(SS1);
SS2:=((((SS AND (SS1B < SSSB)) AND (B3B < B2B)) AND (SS1B > 0)) AND (COUNT(SS,B2B) < 3));
SSSS:=(SSS AND (REF(SSSB,1) > REF(B1B,1)));
DRAWICON((B1 = 1),(LOW - 0.1),1);
DRAWTEXT((B1 = 1),(LOW - 0.25),买1),colorFF;
DRAWICON((B2 = 1),(LOW - 0.1),1);
DRAWTEXT((B2 = 1),(LOW - 0.25),买2),colorFF;
DRAWICON((B3 = 1),(LOW - 0.1),1);
DRAWTEXT((B3 = 1),(LOW - 0.25),买3),colorFF;
DRAWICON((SS1 = 1),(HIGH + 0.1),2);
DRAWTEXT((SS1 = 1),(HIGH + 0.25),止损1),colorFF00;
DRAWICON((SS2 = 1),(HIGH + 0.1),2);
DRAWTEXT((SS2 = 1),(HIGH + 0.25),止损2),colorFF00;
DRAWICON((SSSS = 1),(HIGH + 0.1),2);
DRAWTEXT((SSSS = 1),(HIGH + 0.25),快卖),colorFF00;

【免责声明】期市有风险,入市须谨慎。本机构或本人的分析、观点仅供参考,不作为投资决策的依据。本企业不承担任何投资

行为产生的相应后果。

转载请注明信息来源:中投期货

网友留言

    暂无记录

我要评论

* 留言人:
* 留言内容:
*验证码:
 
Copyright @ 2020 澳门威斯人8040 com-威澳门尼斯人8040com版权所有 

澳门威斯人8040 com|威澳门尼斯人8040com

XML 地图 | Sitemap 地图